annulla
Visualizzazione dei risultati per 
Cerca invece 
Intendevi dire: 
annulla
Visualizzazione dei risultati per 
Cerca invece 
Intendevi dire: 

Cerca soluzioni, condividi esperienze, chiedi un consiglio alla Community TIM

×

Cisco 887VA Voice - configurazine VOIP

RISOLTO
Astronauta II livello

Cisco 887VA Voice - configurazine VOIP

Sono in possesso dei dati forniti da TIM per la configurazione del VOIP su un router generico, sono un fortunato possessore di un Cisco 887VA-Voice che ha 4 porte FXS, sono riuscito a configurare la parte VDSL2 del mio contratto FTTC ma ora sto incontrando difficolta nel configurare la parte VOIP, sto provando la registrzione ma senza successo.

 

Qualcuno ha una configurazione del FUNIONANTE,  mi immagino che forse il problema derivi dall'autenticazione, quella sip key come va messa??

 

HELP

1 SOLUZIONE ACCETTATA

Soluzioni accettate
Astronauta II livello

Rif.: Cisco 887VA Voice - configurazine VOIP

Dopo 2 giorni di prove sono riuscito a farlo funzionare, sia per le chiamate iningresso che per le chiamate in uscita.

 

Recupero dell'indirizzo del Server

Lanciare NSLOOKUP con server quello fronito da TIM 

digitare set q=SRV

digitare _sip._udp.<il nome dell'outboundproxy che vi a dato TIM>

nella risposta troverete qualcosa di simile svr hostname = nat01mimims01.co.imsw.telecomitalia.it

digitare set q=a

digitare nat01mimims01.co.imsw.telecomitalia.it

nella risposta troverete qualcosa di simile Address: 5.97.53.10

prendete nota dell'indirizzo IP

 

Segue la configurazione di un CISCO 887VA-V ma dovrebbe funzionare

con qualsiasi altro oggetto con  IOS15.4 e advipservices

 

!associazione ip al sip-domain telecomitalia.it richiesto da TIM
ip host telecomitalia.it <IP RICAVATO DA NSLOOKUP>
!
ip dhcp excluded-address 192.168.1.1 192.168.1.31
ip dhcp pool 0
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
domain-name myhouse.local
dns-server 192.168.1.1
lease 7
!
controller VDSL 0
operating mode vdsl2
!necessario per il Vectoring utilizzato da TIM nella modulazione DSL
firmware filename flash:VA_A_38k1_B_38h_24g1.bin
!
!
voice service voip
!protezione contro toll fraud
ip address trusted list
ipv4 <IP RICAVATO DA NSLOOKUP>
callmonitor
fax protocol pass-through g711alaw
modem passthrough nse codec g711alaw
sip
bind control source-interface Dialer0
bind media source-interface Dialer0
outbound-proxy dns:<FQDN FORNITO DA TIM>
early-offer forced
no call service stop
!
!precedenza dei codec come da info su sito TIM
voice class codec 1
codec preference 1 g711alaw
codec preference 2 g729r8
codec preference 3 g722-64
!
!precedenza dei QOS DSCP 40 come da info su sito TIM
class-map match-all voip
match access-group 102
!
policy-map dscp_voip
class voip
set ip dscp cs5
!
interface Ethernet0
no ip address
!
interface Ethernet0.835
encapsulation dot1Q 835
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Vlan1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
ip tcp adjust-mss 1452
hold-queue 100 out
!
interface Dialer0
ip address negotiated
!ulteriore protezione contro il Toll Fraud
ip access-group 107 in
ip mtu 1452
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname aliceadsl
ppp chap password aliceadsl
ppp pap sent-username aliceadsl password aliceadsl
ppp ipcp dns request
!applicazione del QOS in uscita
service-policy output dscp_voip

!
!abilita il router ad essere un server DNS utilizza quelli forniti dal provider
!in caso di uso del dhcp fornire ai client l'indirizzo del router come DNS
ip dns server

!

ip nat inside source list 1 interface Dialer0 overload
ip route 0.0.0.0 0.0.0.0 Dialer0
!
! Access List per il NAT
access-list 1 permit 192.168.1.0 0.0.0.255
!
!Access List per proteggere l'accesso in Telnet
access-list 30 permit 192.168.1.0 0.0.0.255
!
!Access List per selezionare il traffico da marcare con DSCP 40
access-list 102 permit ip any host <IP RICAVATO DA NSLOOKUP>
!
!Access List per limitare l'accesso al voip solo ai server TIM (protezione contro TOLL FRAUD)
access-list 107 permit udp host <IP RICAVATO DA NSLOOKUP> any eq 5060
access-list 107 permit tcp host <IP RICAVATO DA NSLOOKUP> any eq 5060
access-list 107 deny udp any any eq 5060
access-list 107 deny tcp any any eq 5060
access-list 107 deny udp any any eq 1720
access-list 107 deny tcp any any eq 1720
access-list 107 permit ip any any
!
voice-port 3
cptone IT
! Accorcia il tempo di INTERDIGIT per evitare di usare il #
! per terminare la composizione di numeri a lunghezza variabile
timeouts interdigit 2
station-id number <NUMERO SENZA +39>
caller-id enable
!
dial-peer voice 100 pots
destination-pattern <NUMERO CON +39........>
port 3
!
dial-peer voice 1000 voip
destination-pattern .T
session protocol sipv2
session target dns:telecomitalia.it
voice-class codec 1
dtmf-relay rtp-nte
no vad
!
sip-ua
authentication username <NUMERO CON +39........> password <SIP-KEY da 64 digit> realm telecomitalia.it
registrar dns:telecomitalia.it expires 3600 auth-realm telecomitalia.it
!
ntp server 31.14.131.188
!
end

 

 

 

Visualizza soluzione nel messaggio originale

1 RISPOSTA 1
Astronauta II livello

Rif.: Cisco 887VA Voice - configurazine VOIP

Dopo 2 giorni di prove sono riuscito a farlo funzionare, sia per le chiamate iningresso che per le chiamate in uscita.

 

Recupero dell'indirizzo del Server

Lanciare NSLOOKUP con server quello fronito da TIM 

digitare set q=SRV

digitare _sip._udp.<il nome dell'outboundproxy che vi a dato TIM>

nella risposta troverete qualcosa di simile svr hostname = nat01mimims01.co.imsw.telecomitalia.it

digitare set q=a

digitare nat01mimims01.co.imsw.telecomitalia.it

nella risposta troverete qualcosa di simile Address: 5.97.53.10

prendete nota dell'indirizzo IP

 

Segue la configurazione di un CISCO 887VA-V ma dovrebbe funzionare

con qualsiasi altro oggetto con  IOS15.4 e advipservices

 

!associazione ip al sip-domain telecomitalia.it richiesto da TIM
ip host telecomitalia.it <IP RICAVATO DA NSLOOKUP>
!
ip dhcp excluded-address 192.168.1.1 192.168.1.31
ip dhcp pool 0
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
domain-name myhouse.local
dns-server 192.168.1.1
lease 7
!
controller VDSL 0
operating mode vdsl2
!necessario per il Vectoring utilizzato da TIM nella modulazione DSL
firmware filename flash:VA_A_38k1_B_38h_24g1.bin
!
!
voice service voip
!protezione contro toll fraud
ip address trusted list
ipv4 <IP RICAVATO DA NSLOOKUP>
callmonitor
fax protocol pass-through g711alaw
modem passthrough nse codec g711alaw
sip
bind control source-interface Dialer0
bind media source-interface Dialer0
outbound-proxy dns:<FQDN FORNITO DA TIM>
early-offer forced
no call service stop
!
!precedenza dei codec come da info su sito TIM
voice class codec 1
codec preference 1 g711alaw
codec preference 2 g729r8
codec preference 3 g722-64
!
!precedenza dei QOS DSCP 40 come da info su sito TIM
class-map match-all voip
match access-group 102
!
policy-map dscp_voip
class voip
set ip dscp cs5
!
interface Ethernet0
no ip address
!
interface Ethernet0.835
encapsulation dot1Q 835
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Vlan1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
ip tcp adjust-mss 1452
hold-queue 100 out
!
interface Dialer0
ip address negotiated
!ulteriore protezione contro il Toll Fraud
ip access-group 107 in
ip mtu 1452
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname aliceadsl
ppp chap password aliceadsl
ppp pap sent-username aliceadsl password aliceadsl
ppp ipcp dns request
!applicazione del QOS in uscita
service-policy output dscp_voip

!
!abilita il router ad essere un server DNS utilizza quelli forniti dal provider
!in caso di uso del dhcp fornire ai client l'indirizzo del router come DNS
ip dns server

!

ip nat inside source list 1 interface Dialer0 overload
ip route 0.0.0.0 0.0.0.0 Dialer0
!
! Access List per il NAT
access-list 1 permit 192.168.1.0 0.0.0.255
!
!Access List per proteggere l'accesso in Telnet
access-list 30 permit 192.168.1.0 0.0.0.255
!
!Access List per selezionare il traffico da marcare con DSCP 40
access-list 102 permit ip any host <IP RICAVATO DA NSLOOKUP>
!
!Access List per limitare l'accesso al voip solo ai server TIM (protezione contro TOLL FRAUD)
access-list 107 permit udp host <IP RICAVATO DA NSLOOKUP> any eq 5060
access-list 107 permit tcp host <IP RICAVATO DA NSLOOKUP> any eq 5060
access-list 107 deny udp any any eq 5060
access-list 107 deny tcp any any eq 5060
access-list 107 deny udp any any eq 1720
access-list 107 deny tcp any any eq 1720
access-list 107 permit ip any any
!
voice-port 3
cptone IT
! Accorcia il tempo di INTERDIGIT per evitare di usare il #
! per terminare la composizione di numeri a lunghezza variabile
timeouts interdigit 2
station-id number <NUMERO SENZA +39>
caller-id enable
!
dial-peer voice 100 pots
destination-pattern <NUMERO CON +39........>
port 3
!
dial-peer voice 1000 voip
destination-pattern .T
session protocol sipv2
session target dns:telecomitalia.it
voice-class codec 1
dtmf-relay rtp-nte
no vad
!
sip-ua
authentication username <NUMERO CON +39........> password <SIP-KEY da 64 digit> realm telecomitalia.it
registrar dns:telecomitalia.it expires 3600 auth-realm telecomitalia.it
!
ntp server 31.14.131.188
!
end

 

 

 

Visualizza soluzione nel messaggio originale

Unisciti alla Community

Le Star della Community

Astronauta Iperconnesso
14
Comandante spaziale I livello
8
Moderatore
8
Comandante spaziale III livello
7
Astronauta II livello
6
Astronauta Iperconnesso
6